Output voltage of unity-gain buffer varying with current?

Got a hardware problem? ask for help

Output voltage of unity-gain buffer varying with current?

Postby kimi » April 27th, 2017, 3:50 am

I'm working on a VLC+IR transmitter that runs from batteries. I decided to use an LM317 so that the discharging battery wouldn't really affect the current through the LEDs. (Disclaimer: I've never worked with this IC before in my life.) I use TINA for simulations and I found a spice model of the 317 somewhere on the internet.* Its output voltage dropped when connecting the LEDs, so I connected a unity-gain buffer op-amp between the two.
Image
The transmitter has two "outputs": a white and an IR LED. They can work together or one-by-one. VG1 and VG2 are square waves with a frequency of 1 MHz. When I turn off SW-SPST2 or SW-SPST3, the other is working properly. However, when I try to operate them at the same time, one of them stops behaving normally. I checked the op-amps output voltage (VM3), and it keeps changing between 2 and 5 volts, approximately. I don't understand why, as the op-amp has a really low output impedance, thus the output voltage shouldn't be affected by the load.
Image
So, my question is: First, what is the cause? Simply a simulation mistake? Second, I'm not really convinced that the LM317 model is correct, so, am I correct assuming, that its output voltage drops with a load?
kimi
 
Posts: 4
Joined: August 11th, 2016, 8:01 pm

Re: Output voltage of unity-gain buffer varying with current

Postby k-ww » April 27th, 2017, 3:00 pm

A good rule of thumb is:

If the power supply droops, increase the capacitance - I would add 100 uf caps to the input and output of the LM317.

Also, how close is the bypass cap to the buffer amp - inches = microhenries of inductance in series with the cap.

Look over the spec sheet of the LM317 and don't rely on the spice model, unless it has a roll-off for frequency response included.

There are many 'flavors' of the LM317, and they vary in current output/heat dissipation ability.
User avatar
k-ww
 
Posts: 1282
Joined: February 17th, 2011, 10:47 am


Return to Help me! Hardware

Who is online

Users browsing this forum: No registered users and 2 guests